[CALUG] jikes Java complier can't find java.lang

Jim Sansing jjsansing at verizon.net
Wed Jun 6 20:19:19 EDT 2007

Oh boy!  Well, Java is kind of like C/C++, but not really,
and kind of like Perl, but not really, and kind of like a few
other languages, but not really.

I have used Sun java and Eclipse successfully.  For both,
the hardest part was the classpath.  However, I'm sure that
you have to have the PATH and LD_LIBRARY_PATH
set correctly first.  In Jikes that is probably the sourcepath
and maybe the bootclasspath.  The LD_LIBRARY_PATH
must be set to any *.so files that are needed if they are not
in the standard lib directories (Eclipse has some of its own).

After that, the classpath includes:
- directories with any *.class files to be run
- the path to any *.jar files imported by *.class or
  other *.jar files
Which implies that you know:
- what *.jar files are being imported (you'll get messages
  about these--one at a time as they are added to classpath)
- where those *.jar files are located

If this is really important, you might get some help from the
Jikes forums.

Good luck.

Later . . .   Jim

Eldon Ziegler wrote:
>This is the first time I've ever intentionally tried to use java so
>there is no reason to suspect it worked before.
>On Wed, 2007-06-06 at 16:03 -0400, Jim Sansing wrote:
>>If you have used Jikes for other apps, then I can't help
>>you.  But I'm guessing the sourcepath is the probable
>>culprit, since java.lang is a core component.  I haven't
>>used Jikes, but I tried using kaffe under Debian and
>>found that it was not installed in /usr/java the way
>>Sun's java is. But the Debian kaffe package was
>>set up to at least find the core language components.
>>Later . . .   Jim
>>Eldon Ziegler wrote:
>>>I downloaded a java app that uses the jikes compiler but running it
>>>results in 
>>>Found 1 system error:
>>>*** Semantic Error: You need to modify your classpath, sourcepath,
>>>bootclasspath, and/or extdirs setup. Jikes could not find package
>>>"java.lang" in: 
>>>               .
>>>               .
>>>make: *** [vncviewer.jar] Error 1
>>>What should classpath, etc be set to?
>>>CALUG mailing list
>>>CALUG at unknownlamer.org
>>CALUG mailing list
>>CALUG at unknownlamer.org

More information about the CALUG mailing list