[CALUG] iPod Nano, Amarok and Music Player

Rajiv Gunja opn.src.rocks at gmail.com
Tue Apr 7 19:55:00 EDT 2009


If you are using Amarok 2.x, then I am afraid it will not work. I have a
Video iPod and it works very well with Amarok 1.4.10.

When I moved to Mandriva 2009, Amarok 2.x was default and I had to uninstall
it and install 1.4.10, to have my iPod work with Amarok.

After spending about 3 months on Mandriva 2009 and PCLinuxOS 2009 not being
up to the mark as version 2007, I switched to Gentoo based Sabayon Linux

To make my iPod work, (it worked without any intervention with PCLOS 2007
and Mandriva 2009), I had to installed a few more addons:
*Package: app-pda/gtkpod-0.99.14
Package: app-pda/ipodslave-0.7.3
Package: media-libs/libgpod-0.7.0
Package: media-libs/libipoddevice-0.5.3
Package: media-plugins/quodlibet-ipod-0.4-r1

Amarok version installed:
*Package: media-sound/amarok-1.4.10-r1

When you detect your ipod, make sure you mount it with the right options:
*agni40 ~ # lsusb  | grep iPod*
*Bus 001 Device 003: ID 05ac:1209 Apple, Inc. iPod Video*

*agni40 ~ # ls -ld /media/GUNJAS_S_IP/*
*drwxr-xr-x 8 gunjas root 16384 1970-01-01 00:00 /media/GUNJAS_S_IP/*

*agni40 ~ # mount | grep GUN*
*/dev/sdc2 on /media/GUNJAS_S_IP type vfat

After all this I got the following error: *libgpod.so.3: cannot open shared
object file: No such file or directory*
To solve this, I create a soft-link under /usr/lib :* ln -s libgpod.so.4.0.0

It works without issue now. If you are facing different errors, please share
the message or screenshot. Thanks


Rajiv G Gunja
Blog: http://ossrocks.blogspot.com

2009/4/7 Ed Browne <edward_d_browne at yahoo.com>

> I'm trying to manage a 4th Generation iPod nano on linux,
> on Ubuntu with a 2.6.24 kernel.  I read a couple of good
> entries on using Amarok to manage it.  It doesn't quite
> work, but I think I'm getting close.  I'll gladly accept any
> advice on this, but what's really getting in my way right
> now is something much simpler - how do you get this
> damn Music Browser to stop launching itself over and
> over on the iPod (I woudn't mind if it worked, but it
> definitely doesn't)?   I tried going to System->Preferred
> Applications->Multimedia, where Music Browser
> was specified, but even changing that to Amarok doesn't
> cause Amarok to launch in place of Music Browser,
> Music Browser just keeps launching itself.
> Thanks again - Ed
> _______________________________________________
> CALUG mailing list
> CALUG at unknownlamer.org
> http://lists.unknownlamer.org/listinfo/calug
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.unknownlamer.org/pipermail/calug/attachments/20090407/2fcc2095/attachment.htm 

More information about the CALUG mailing list