[CALUG] Does Ubuntu 16.04 Software Updater not understand USB eth0?

Ed Browne edward_d_browne at yahoo.com
Mon Dec 5 11:23:26 EST 2016

BTW, there's a 40KB limit on posting to this list, and something/someone bloats the hell out of what I post (maybe it's yahoo) so I'm going to have to butcher the hell out of my measly little text-only post to get it through.  Apologies.
Hello CALUG,         I don't even know where to begin with this.  It all goes back to a motherboard I bought 3 years ago, with a built-in ethernet chipset (RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller) that just doesn't seem well-supported by Linux.  I tried to fix it then but eventually gave up and just started using a USB-to-ethernet adapter, which worked fine for years.         This week I decided to upgrade from Ubuntu 15.10 to 16.10, in two hops.  The first hop, from 15.10 to 16.04.1 LTS, worked perfectly fine.  But when I try to do the 16.04 to 16.10 upgrade, I get all sorts of errors, from start to finish, that I've never gotten before.  Starting with:---------------------------------------------------------------------------------------------------------------------------------------------
 $ sudo apt-get update
Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:2 http://archive.canonical.com/ubuntu saucy InRelease                                 
Hit:3 http://de.archive.ubuntu.com/ubuntu xenial InRelease                                                                                 
Get:10 http://dl.google.com/linux/chrome/deb stable Release.gpg [916 B]                                                        
Get:7 http://de.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]                                                                
Get:8 http://deb.opera.com/opera-stable stable InRelease [2,592 B]                                                 
Err:3 http://de.archive.ubuntu.com/ubuntu xenial InRelease                                                                      
  At least one invalid signature was encountered.http://dl.goog 
W: Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/Release.gpg  At least one invalid signature was encountered.
W: Some index files failed to download. They have been ignored, or old ones used instead.

I have no idea if those errors are fatal or not (as per google, I tried tinkering with the /etc/apt/sources.list file , which reduced the number of errors, but still left many errors.  But the file seems to be restored to its original condition regardless of what I do.)
Then I do "sudo do-release-upgrade" (I'll put what I can of output below my comments, because it's so long.)  It says 

"Error during update 
A problem occurred during the update. This is usually some sort of 
network problem, please check your network connection and retry. "
But clearly there is no network problem (I'm emailing you from that very machine), unless maybe it's confused by the USB ethernet adapter or some such thing??  Everything I'm doing is identical to what I did for the 15.10->16.04 upgrade, which worked fine. So what can I be doing wrong?
Thanks very much, and cheers - Ed

$ sudo do-release-upgrade
Checking for a new Ubuntu release
Get:1 Upgrade tool signature [198 B]                                                                                                                                                                                                                         
Get:2 Upgrade tool [1,258 kB]                                                                                                                                                                                                                                
Fetched 1,258 kB in 0s (0 B/s)                                                                                                                                                                                                                               
authenticate 'yakkety.tar.gz' against 'yakkety.tar.gz.gpg' 
extracting 'yakkety.tar.gz'...Err http://deb.opera.com/opera-stable stable InRelease                                                                                                                                                                                                       
  At least one invalid signature was encountered.                                                                                                                                                                                                            
Ign http://security.ubuntu.com/ubuntu yakkety-security InRelease                                                                                                                                                                                             
Ign http://de.archive.ubuntu.com/ubuntu yakkety InRelease                                                                                                                                                                                                    
Ign http://de.archive.ubuntu.com/ubuntu yakkety-updates InRelease                                                                                                                                                                                            
Ign http://de.archive.ubuntu.com/ubuntu yakkety-backports InRelease                                                                                                                                                                                          
Fetched 567 kB in 0s (0 B/s)                                                                                                                                                                                                                                 

Error during update 

A problem occurred during the update. This is usually some sort of 
network problem, please check your network connection and retry. 

Restoring original system state

Reading package lists... Done    
Building dependency tree          
Reading state information... Done
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.unknownlamer.org/pipermail/calug/attachments/20161205/188bbd70/attachment-0001.html>

More information about the CALUG mailing list