[CALUG] moving files between linux and windows

Bryan Smith b.j.smith at ieee.org
Mon Nov 6 23:28:58 EST 2017

Sorry, correction on the Rufus link (the GitHub page is not ideal if
you just want to download). [2a]

Also remember that some GUI tools are problematic.

Microsoft admitted that pre-Windows 10, Explorer.EXE could regularly
and consistently cause corruptions.  In Windows 10, there are still
issues, but Microsoft hasn't fessed up to them ... yet.  I install
TeraCopy, which uses rsync underneath, which gives you options right
in Explorer to copy with it instead.

On Linux, the Desktop Environment's File Manager, or alternatives,
will vary greatly.  I use PC-FileMan for small tasks, but I still
prefer rsync (typically I use -aAHSXxv to get all Extended
Attributes).  When it comes to boot/root, I still prefer dump/restore.

- bjs

[2a] https://rufus.akeo.ie/

On Mon, Nov 6, 2017 at 11:24 PM, Bryan Smith <b.j.smith at ieee.org> wrote:
> Built-in Windows tools will not create a FAT32 file system larger than
> 32GiB (33.8GB).  Are you sure it's not creating exFAT (64-bit FAT)?
> [1]
> Windows also doesn't like larger than 128GiB (137GB).  The theoretical
> limit of FAT32 is 8TiB, but I seriously doubt most Windows systems
> prefer that.
> That all said ...
> For removable/portable USB devices, I highly recommend Rufus.  Rufus
> is the only tool I use for making anything I'm going to use with
> Windows, and especially for creating Windows 7, 8.x and 10 uEFI
> installation media.
> - bjs
> [1] http://wikipedia.org/wiki/ExFAT
> [2] https://github.com/pbatard/rufus
> On Mon, Nov 6, 2017 at 10:27 PM, Howard <how0909 at freeshell.org> wrote:
>> So your saying when you format the drive fat32 in windows it reads ok on the
>> centos but then after having in the centos the win7 barfs and you have to
>> reformat?
>> And your centos file manglers don't see ntfs well?
>> Did you try command line?
>> Screw the gui stuff.
>> I had a bad experience last year when I tried copying a good size tree from
>> a fedora to an external hard drive. It stopped after about 1/8 and I though
>> it did it all. Never looked for myself and then dumped the fedora install
>> and when I went to use my backed up stuff found out I lost a major portion.
>> Some really important. I'll never do that again!
>> Try the command line and at least do a du when done.
>> Howard():
>> On 11/06/2017 07:24 PM, Walt Smith wrote:
>>> Windows
>>> Format will do fat32 and try 16kb sector size -- Linux writes ok
>>> But windows barfs. gain, if
>>>   you tried...
> --
> Bryan J Smith  -  http://www.linkedin.com/in/bjsmith
> E-mail:  b.j.smith at ieee.org  or  me at bjsmith.me


Bryan J Smith  -  http://www.linkedin.com/in/bjsmith
E-mail:  b.j.smith at ieee.org  or  me at bjsmith.me

More information about the CALUG mailing list